Devi essere registrato per usare la shout!

Autore Topic: Mediaportal 1.0.2 + Oscam + MDApiFilter + Mediaset Premium (Help)  (Letto 1661 volte)

Offline lnaimi

  • Interessato
  • **
  • Ringraziamenti
  • -lasciati: 0
  • -ricevuti: 0
  • Post: 105
  • Karma: 0
E' giorni che provo a configurare Mediaportal con MDApiFilter per vedere una tessera Mediaset Premium configurata su Oscam.
Vi faccio il punto della situazione: ho un piccolo serverino linux su cui è installato Ubuntu 8.04 e il programma Oscam (ultima svn). Al serverino è attacato via USB un lettore di smartcard in cui è infilata una delle ultime tessere MP (quelle che non scadono mai). Allora all'avvio di oscam tutto a posto: log pulito e senza nessun messaggio di avvertimento.
Su un altro computer ho installato MediaPortal 1.0.2 con la versione di MDAPIFilter 2009. Quest'ultimo comunica perfettamente con oscam da quel che posso vedere dal log quando avvio il timeshift del tvserver.
Ora arrivano i problemi: da guide sparse su internet per configurare mediaset su oscam devo lavorare su i CAID 1802 o 1803 e su i PID 8c11 o 8d11. Queste 2 soluzioni non vanno bene per me, in quanto il log di oscam mi dice che i servizi non sono stati trovati. Navigando scopro che per vedere il CAID su cui opera la mia tessera mediaset devo andare a vedere il menu del decoder e così scopro che la mia tessera opera su CAID 1805 e PID 0d11. A questo punto configuro oscam per operare su tali parametri. Non ottengo più i messaggi di errore nel log di oscam ma mediaportal mi rimane bloccato. Analizzando dopo varie prove il log di MDAPI noto che alcune (solo alcune) volte i pacchetti che vengono inviati a oscam tornano in qualche modo errati.
Tutto questo mi sta facendo impazzire.
Vi posto la mia configurazione di oscam:

oscam.server
[reader]
label    = m7
protocol = pcsc
device   = 0
mhz    = 357
cardmhz = 368
EMMCache = 1,1,1
group    = 1
caid     = 1805
fallback = 0
tiger_rsakey = A9..B5

oscam.conf
[global]
logfile             = /var/log/oscam.log
clienttimeout       = 5
maxlogsize          = 50
waitforcards        = 1
nice                = -19
level               = 15
cachedelay          = 120

[monitor]
port                = 988
nocrypt             =
aulow               = 120
hideclient_to       = 0
monlevel            = 4
appendchaninfo      = 0

[newcamd]
port                = 10001@1805:8d11
key                 = 0102030405060708091011121314

[webif]
httpport            = 8888
httpuser            = ****
httppwd             = ****
httpcss             =
httptpl             =
httpscript          =
httprefresh         = 4
httpallowed         = 0.0.0.0-255.255.255.255
httpdyndns          =
httphideidleclients = 0
httpreadonly        = 0

[anticasc]
enabled             = 0
numusers            = 0
sampletime          = 2
samples             = 10
penalty             = 0
aclogfile           = ./oscam_ac.log
denysamples         = 8
fakedelay           = 1000

oscam.user
[account]
user = nagra
pwd = nagra
monlevel = 4
uniq = 0
group = 1
au = m7
caid = 1805
ident = 1805:8d11

La configurazione di MDAPIFilter è fatta come da manuale. Ho abilitatata la CAM sulle schede che devono essere collegate ad oscam e limitato il numero di canali da decriptare a 1.

Ho notato dal log di MDAPIFilter un messaggio abbastanza criptico : CAID changed! from (0) to (1802). Come faccio a forzarlo a 1805 (se questo è necessario).
Spero mi possiate dare una mano.
Case: ASUS | CPU: AMD Atlhon 64 X2 4850E AM2 | Front-End: Mediaportal 1.1 RC5 | Mainboard: Asus M3A78-EM | Scheda Grafica: ATI radeon HD 3200 | Telecomando: MCE | Tuner TV: Hauppauge NOVA-T PCI + Hauppauge NOVA STICK USB | TV: Bloom LCD 20" 800x600